Aller au contenu
Forum Photo Paris
Bambix

[RESOLU] Etrange écart entre export Lr et upload forum

Recommended Posts

Bambix   

Hello.

 

J'allais faire une proposition dans "votre regard sur les toits parisiens" et j'ai été choqué (et ai failli vomir d'émotion) quand j'ai vu l'écart de dynamique et de couleurs entre la photo quz j'ai sorti de Lr et celle sur le forum.

 

Ici à gauche ma photo sortie de Lr et lu par la liseuse de windows (fidèle à mon travail sous Lr) et à droite la photo telle qu'elle apparait sur le forum.

 

WADAFAQ ?! Vous sauriez m'éclairer ?

 

 

wtf.PNG

Modifié par Bambix

Partager ce message


Lien à poster
Partager sur d’autres sites
Alphapix   

J'ai u un problème de ce type a la création de mon site. Regarde si ça le fait toujours en changeant le profil couleur dans l'export lightroom. Tu passe en srvb jpence ça peut être ça

Partager ce message


Lien à poster
Partager sur d’autres sites
Bambix   

Merci !! Je passais en prophoto pour une raison obscure ! Problème résolu ^^

Partager ce message


Lien à poster
Partager sur d’autres sites
Bambix   
il y a 1 minute, A-snowboard a dit :

une visionneuse windows fidèle aux couleurs ? ça existe ? oO

 

Je sais pas, mais même en prophoto, la visionneuse est plus fidèle que le forum ...

Partager ce message


Lien à poster
Partager sur d’autres sites
Alphapix   
Il y a 7 heures, Bambix a dit :

Merci !! Je passais en prophoto pour une raison obscure ! Problème résolu ^^

 j'étais aussi en prophot ;)

Partager ce message


Lien à poster
Partager sur d’autres sites
rhavia   

Hello,

 

j'avais exactement le même genre de problèmes sur mon écran car les navigateurs par défat ne gere pas ou mal les profils de couleurs étendu.

Pour régler le problème il faut utiliser un navigateur qui sait gérer les profils de couleurs (ICC) et en plus paramétrer le profil par défaut.

 

En clair le problème ne vient pas de l'image mais de ton navigateur.

 

Plus précisément par défaut ton navigateur va convertir les profiles ICC de tes photo vers le profile standard (RGB) puis ton écran va reconvertir dans le profile de ton écran et le résultat peut être bizzare. (chez moi un dégradé de gris se transforme en du noir et gris sur 2 tons..)

 

 

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 3 heures, rhavia a dit :

Hello,

 

j'avais exactement le même genre de problèmes sur mon écran car les navigateurs par défat ne gere pas ou mal les profils de couleurs étendu.

Pour régler le problème il faut utiliser un navigateur qui sait gérer les profils de couleurs (ICC) et en plus paramétrer le profil par défaut.

 

En clair le problème ne vient pas de l'image mais de ton navigateur.

 

Plus précisément par défaut ton navigateur va convertir les profiles ICC de tes photo vers le profile standard (RGB) puis ton écran va reconvertir dans le profile de ton écran et le résultat peut être bizzare. (chez moi un dégradé de gris se transforme en du noir et gris sur 2 tons..)

 

C'est un peu plus complexe que ça à mes yeux : (mes les informaticiens du forum seront plus à même de préciser les infos)

 

Il y a certes la capacité du navigateur à bien lire le profil (sachant que sur le web, on est plus sur le srgb sur que sur rgb). Mais il y a aussi la transformation de l'image au sein du site web.
Car l'image est importé sur le site web, et celle qui s'affiche n'est pas nécessairement le fichier original. Donc pendant la conversion, certaines infos peuvent sauter. (les exifs par exemple).

 

Bref, tout ça pour dire que déjà sur le pc, il faut exporter en srgb pour le web. Déjà ça élimine une source potentielle de conflit.

 

 

Après @rhavia peut être que tu as des notions que je ne connais pas, je peux me planter moi aussi :)

Partager ce message


Lien à poster
Partager sur d’autres sites
rhavia   

En fait, je suis informaticien ;)

 

mais tu n'as pas totalement tort : certains site peuvent en effet appliquer des modifications aux images affichées, soit lors de l'import de l'image soit lors de l'affichage pour coller au site. Mais les cas ou ils y a des modifications à l'affichage sont plutôt rare à ma connaissance.

 

Après le problème est complexe car il y a plusieurs possibilités :

Cela peut venir de l'image, du navigateur ou de l'écran, ou plusieurs a la fois ou de tous en même temps ...

Il existe également plusieurs profiles (rgb, srgb, argb ...) et chaque écran peut également interpréter les informations non spécifiés à sa manière, il n'y a pas de norme.

 

Dans mon cas mon écran couvre le sRGB mais pas aRGB.

Il n'est précisé nulle part comment l'écran affiche des images ayant un profile aRGB, et sauf à tester en prenant une photo d'une image affichée sur l'écran, impossible à comparer ..

Maintenant on peut supposer que les constructeurs d'écrans font plutôt bien leur boulot, et donc savent gérer ce genre de problèmes.

 

NB que je ne parle pas des problèmes pouvant être lié aux sites, car je pense que ce point n'est pas relevant : en effet je ne suis pas sur que le HTML puisse le faire directement, donc il s'agirait de script en amont du HTML et donc potentiellement cela ne serait pas si problématique que ca.

 

Les 2 probables sources d'erreur sont plus vraisemblablement l'image elle-même ou le navigateur.

 

Dans le cas de l'image : si le profile ICC n'est pas exporté ou a été effacé par le site, il ne s'agit la que d'une information complémentaire, les couleurs de l'images n'en restent pas moins les couleurs originales et donc on devrait pouvoir spécifier le profile utilisé (ou mieux, être détecté).

 

Le point le plus problématique reste donc les navigateurs qui commencent a pein a intégrer la gestion des profiles ICC et encore, dans la majorité des cas, les fonctionnalités sont en mode bêta voire alpha et non accessible simplement.

Des sujets sont ouvert aupres des éditeur mais ils sont loin d'être une priorité puisque finalement peu de gens utilise ce genre de choses dans la "vie courante".

 

Partager ce message


Lien à poster
Partager sur d’autres sites

C'est bien pour ça que je prenais mes pincettes dans mes propos, de peur de dire une grosse connerie de façon affirmative ^^

 

L'écran fait plutôt du bon job... Si l'ordinateur lui dit quel est le profil de l'image.

Je dis ça, car j'ai un écran RGN d'un coté et un autre sRGB, donc j'ai les problématiques des profils assez fréquemment.

 

Par exemple la visionneuse windows est à la rue pour les profil, alors que nxviewMP est au top quand je coche l'option de lecture des profils ICC... Avec mon écran RGB

Par contre avec mon écran sRGB, avec la même visionneuse windows, c'est les bonnes couleurs.

 

Je n'ai pas testé l'écran RGB avec le système de visionnage par défaut d'apple. Il me semble qu'il gère très bien cette question de profil.

Partager ce message


Lien à poster
Partager sur d’autres sites
rhavia   

Bah je pense que le problème des profiles ICC doit être trop faible pour que les éditeurs de logiciels ne s'en soucient vraiment, mis à part pour les logiciels spécialisés.

 

NB que dans les problèmes remonté sur le sujet, les performances sont souvent mises en cause, ce qui laisse supposer que les logiciels que la gestion des profiles ICC est volontairement délaissé dans la plus part des cas pour ne pas perturber un utilisateur lambda avec une option qu'il ne comprendrait pas et gagner un peu en performances en n'incluant pas un algorithme pour les gérer automatiquement.

 

Du coup perso au final, j'utilise firefox comme navigateur car je peux gérer manuellement les profils et coté windows je me pose pas vraiment la question en fait, les photos je les ouvres systématiquement avec des outils dédiés qui gère cela correctement (acdsee, DXO, paintshop pro, LR et PS ...)

Partager ce message


Lien à poster
Partager sur d’autres sites

De ce que j'ai compris, windows ne s'est jamais trop cassé le cul sur le sujet.

 

 

il y a 34 minutes, rhavia a dit :

Du coup perso au final, j'utilise firefox comme navigateur car je peux gérer manuellement les profils et coté windows je me pose pas vraiment la question en fait, les photos je les ouvres systématiquement avec des outils dédiés qui gère cela correctement (acdsee, DXO, paintshop pro, LR et PS ...)

Mon souci, c'est qu'ouvrir un soft dédié pour juste voir mon jpeg, c'est un peut lourd. (d'ou xnviewMP correctement configuré qui répond a un besoin de remplacer la visionneuse windows).

J'ai fait un topic sur le sujet pour la configuration. C'est juste deux clics.

 

Partager ce message


Lien à poster
Partager sur d’autres sites
rhavia   
Le 24/05/2017 à 13:51, A-snowboard a dit :

Mon souci, c'est qu'ouvrir un soft dédié pour juste voir mon jpeg, c'est un peut lourd. (d'ou xnviewMP correctement configuré qui répond a un besoin de remplacer la visionneuse windows).

J'ai fait un topic sur le sujet pour la configuration. C'est juste deux clics.

 

 

Oups j'avais pas vu la réponse.

Mais oui moi c'est pareil, j'utilise ACDSee qui remplace par défaut la visionneuse Windows, que je trouves bien plus performant et pratique pour visionner les images.

 

NB que pour rendre le logiciel performant, l'image affichée est compressé JPG comme RAW (la valeur est paramétrable) mais du coup on n'affiche pas réellement l'image réelle, il faut l'ouvrir et ne pas rester en mode pré-visu.

NB que dans le cas d'un RAW, l'image affichée est toujours soit la miniature embarqué dans le RAW, soit une interprétation de rendu du logiciel (donc ce n'est jamais réellement "neutre".

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

×